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Error: Unable to resolve plugin Python 'XXXXX\main.py' when running on Gallery
user

Created/Edited - 12/6/2024 by Sophia Cooper | Alteryx

Summary
Article-3440
Description

One of the following errors is seen when executing a workflow on gallery. Generally, this same workflow works fine when run locally in Designer.

Error: Unable to resolve plugin Python 'XXXXX\main.py' (Tool Id: X)
Could not find the plugin directory XXXXX' in 'C:\Users\username\AppData\Roaming\Alteryx\Tools'. 'C:\ProgramData\Alteryx\Tools', or 'C:\Program Files\Alteryx\bin\HtmlPlugins' (Tool ld: X)
Environment
  • Alteryx Server
  • Executing a workflow or application containing one of the following tools:
    • Salesforce Input
    • PowerBI Input/Output
    • OneDrive Input/Output
    • Azure Data Lake Input/Output
    • SharePoint Input/Output
    • Box Input/Output
    • Dataverse Input/Output
    • Google Drive Input/Output
    • Outlook 365 Input
    • ServiceNow Input
    • Tableau Output
Cause

When a user installs a .yxi tool, the tool is added to the tool palette in Alteryx Designer, and the .yxi file and supporting macros are installed in the User's directory. For server executions, this does not work and your Administrator will need to install a .yxi tool for all Server users in order for scheduled jobs and Gallery executions to work.

Resolution

Install the .yxi for all Server users by following this Help article . For multi-node Servers, this will need to be done on all Worker nodes.

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