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Dataflow Job Fails with "ZONE_RESOURCE _POOL_EXHAUSTED" Message
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Created/Edited - 12/6/2024 by Abe Wang | Alteryx

Summary
Article-1065
Issue
When you use Cloud Dataprep to execute a Dataflow job, the job fails with the following message:
Environment
Startup of the worker pool in zone europe-west3-b failed to bring up any of the desired 1 workers. 
ZONE_RESOURCE_POOL_EXHAUSTED: 
The zone 'projects/project/zones/europe-west3-b' does not have enough resources available to fulfill the request. 
Try a different zone, or try again later.
Cause

The ZONE_RESOURCE_POOL_EXHAUSTED error appears when the selected GCP availability zone has no physical machines available to run jobs. This occurs at times of peak utilization in an availability zone, and indicates that all available servers or VMs have been assigned to other customers or workloads.

Resolution

You will need to choose a different availability zone to run your job. 

 

  1. Open the "Run Settings" page for your output.
  2. In the "Run Settings" page, scroll to the section titled, "Dataflow Execution Settings".
  3. Under the "Zone" drop-down menu, select a different availability zone for your job. For example, if the error message indicated that the "europe-west3-b" zone no longer had enough resources, you could select zone "europe-west3-a" for your job execution.
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  1. Click "Run" to save your settings and execute your job in the new availability zone.

 

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