Welcome to the Alteryx Knowledge Base

Error: CURLerror (curl_easy_perform() failed) - code = 6 msg = 'Couldn't resolve host name'. when using a snowflake connection
user

Created/Edited - 12/6/2024 by Darlene Delgado | Alteryx

Summary
When trying to connect to a snowflake database, I am getting the error
CURLerror (curl_easy_perform() failed) - code = 6 msg = 'Couldn't resolve host name'.
Environment
  • Alteryx Designer
    • All versions
  • Alteryx Server
    • All versions
  • Snowflake ODBC
    • All versions

Unable to connect to a snowflake database and receiving the error

 

CURLerror (curl_easy_perform() failed) - code = 6 msg = 'Couldn't resolve  host name'.
Cause

There are multiple causes of this error: 

  • Incorrect Snowflake URL: The URL provided for the Snowflake instance may be incorrect. Ensure that the hostname and domain in the connection string are correct. The URL should be in the format: https://<account_name>.snowflakecomputing.com.

  • DNS Issues: There might be a problem with the DNS (Domain Name System) resolution on the machine running Alteryx Designer or Server. If the DNS server cannot resolve the Snowflake hostname, this error will occur. You can test DNS resolution by trying to ping the Snowflake hostname from the command line.

  • Network Configuration: Firewall or network configurations might be blocking DNS resolution or outbound requests to Snowflake's servers. Ensure that the network allows access to Snowflake's domain and that no proxy or firewall is interfering with the connection.

  • Proxy Settings: If your environment uses a proxy, ensure that the proxy settings are correctly configured in Alteryx Designer/Server. Incorrect or missing proxy configurations can prevent the hostname from being resolved.

  • Alteryx Version Compatibility: Ensure that the version of Alteryx Designer/Server you are using is compatible with the version of the Snowflake ODBC driver you have installed. Sometimes, an outdated or incompatible driver can cause issues.

Resolution
  1. The server name must be left in the format: xxx.snowflakecomputing.com.
  2. Putting the http or https FQDN will cause it to error.
  3. Review and resolve firewall, network, or proxy environment configurations. 
  4. Utilize Alteryx's validated and supported Snowflake ODBC Driver: Snowflake (alteryx.com). 
Was this article helpful?