Welcome to the Alteryx Knowledge Base

Error: "FATAL: no pg_hba.conf entry for host" when saving workflow
user

Created/Edited - 4/22/2026 by George Torres | Alteryx

Summary
A FATAL connect error occurs when trying to publish a workflow to the Gallery that connects to a PostgreSQL database with Kerberos authentication.
Issue

A workflow that connects to a PostgreSQL database with Kerberos authentication runs OK locally on Designer, but when saving to the Gallery the following error is thrown:
 

Error SQLDriverConnect: FATAL: no pg_hba.conf entry for host 'IP_Address', user "username", database 'db_name', SSL off


Environment
  • Alteryx Server
    • 2020.4
  • Alteryx Designer
    • 2020.4
  • Workflow Tools
    • Input/Output Data
    • Connect In-DB
  • Simba PostgreSQL ODBC Driver
    • 1.4.32.1
  • PostgreSQL Database
    • 13
    • Kerberos Authentication
Cause

The error indicates that there was a failed authentication attempt to the database, so the connection couldn't be established.

The issue is a permissions-related issue on the user reported within the error message. This may be a 'Run As' user if one is set up on the Alteryx Server when publishing to the Gallery.

Resolution

1. Check if the ODBC driver is configured correctly per the Simba PostgreSQL Configuration Guide. Step 10 has the configuration requirements for Kerberos.

2. Consult the PostgreSQL admin to check the following:
 

  • Grant the appropriate permissions to the affected user.
  • Ensure the appropriate SSL options are selected in the ODBC drivers.
  • It may be necessary to update the pg_hba.conf file to allow the user to access the database, for example.
  • Ensure firewall exceptions are in place for PostgreSQL.
    • Example of a possible defect on certain versions of PostgreSQL
  • It is recommended to put the fully qualified username and domain within the connection string.

i.e. 
odbc:DSN=myDSN;UID=myUser@domain.net;PWD=__EncPwd1__

Additional Information
  

 

Was this article helpful?