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Error: "Root element is missing" on Input Data tool configured to use Saved Connection
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Created/Edited - 12/17/2025 by Clara Boo | Alteryx

Description
Input Data tool configured to use saved connection is displaying the following error when you click on it in Designer:
 
Root element is missing.
 

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The following error is shown when you step off from the tool and back:
 

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The Recent connections in the Data Connections window will be empty:
 

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Environment
  • Alteryx Designer
    • Version: All
  • Saved Connection
Prerequisites
This issue can also be found if Gallery is not reachable over the network due to a VPN restriction or network policy; it is best to also confirm network issues are not preventing Designer from reaching Gallery and contributing to failure to sync Data Connections before proceeding to troubleshooting XML corruption.
Cause
One of the following connection files is corrupted:
  • C:\Users\<USER>\AppData\Roaming\Alteryx\Engine\UserAlias.xml
  • C:\Users\<USER>\AppData\Roaming\Alteryx\Engine\GalleryAlias.xml
  • C:\ProgramData\Alteryx\Engine\SystemAlias.xml
Note: If any of the files (most likely GalleryAlias.xml) is corrupted, the saved connection will not be loaded.
Resolution

Here are the steps to address the error:

  1. Check if you can successfully open UserAlias.xml in C:\Users\<USER>\AppData\Roaming\Alteryx\Engine and/or SystemAlias.xml in C:\ProgramData\Alteryx\Engine.
  • If yes, please go to the next step.
  • If not, please delete/rename the XML file and recreate the saved connections.
  1. Rename either files to GalleryAlias.xml in C:\Users\<USER>\AppData\Roaming\Alteryx\Engine. If this addresses the error, please delete this file and re-create it by re-syncing the Gallery Data Connections from Options > Advanced Options > Manage Data Connections in Designer.
Additional Information
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