Welcome to the Alteryx Knowledge Base
Created/Edited -
Issue
When installing a Python-based YXI connector in a proxy server or restricted network environment, the installation of the tool may fail. The error will vary, but an example of an error may be:
An error occurred during installation.
ERROR: No matching distribution found for azure-common==1.1.14 (from -requirements.txt (line1))
Environment
- Alteryx Designer/Server
- Python-based YXI Connectors, including:
- Anaplan
- Box
- Dropbox
- Google Drive
- Microsoft Connectors (Azure Data Lake Files, Dataverse, OneDrive, Outlook 365, Power Automate, Power BI, SharePoint)
- Salesforce Input
- ServiceNow
- Tableau Output
- UIPath
Cause
The installation process reaches out through the network to download the required Python packages. Proxies and other network configurations sometimes block these downloads, causing the installation to fail.
Resolution
Confirm that your Designer/Server version is compatible with the version of the tool that you are attempting to install. The compatible versions are outlined in the release notes for that specific tool in our Community Gallery. Once you have confirmed that you are attempting to install a compatible tool version, please reach out to Alteryx Support to obtain a copy of the tool folders to bypass the installation error.
When opening the Support case, make sure to include the following:
- Error message
- Tool name and version
- Designer version
- Download the provided zip file
- Place the zip file under either of the following directories:
- (if on the end user's machine) C:\Users\<username>\AppData\Roaming\Alteryx\Tools
- (if on the Alteryx server) C:\ProgramData\Alteryx\Tools
- Unzip the file to where the specific tool folders are placed directly under either of those two paths. Ensure that there are no nested/duplicate tool folders in the path. The result should look similar to this:
- Open Designer and confirm that the connector tool is available and works as expected.